Mount-lite 2.0.0

Released under the Eclipse Public License

mount, but different and light.

Installation

To install, add the following dependency to your project or build file:

[functionalbytes/mount-lite "2.0.0"]

Topics

Namespaces

mount.extensions.basic

Basic extensions for influencing which states are started or
stopped.

Public variables and functions:

mount.extensions.data-driven

Start a system based on a data configuration.

Public variables and functions:

mount.extensions.explicit-deps

This extension offers more advanced up-to starting and down-to
stopping, by declaring the dependencies of defstates explicitly. It
will only start or stop the transitive dependencies or dependents.

Public variables and functions:

mount.extensions.refresh

An extension that offers helpers for working with the
tools.namespace contrib library. Make sure you add the
tools.namespace to the dependencies of your project yourself. This
extension has been tested with version 0.2.11 of the tools.namespace
library.

Public variables and functions:

mount.lite

The core namespace providing the public API